Jakarta Authorization
2.1
2.0
1.5

This feature enables support for Jakarta Authorization version 2.1 In order to add the appAuthorization-2.1 feature to your server, you need to add the third party provider which is not a part of the Open Liberty profile.

If you are updating your application from using the appAuthorization-2.0 feature to using the appAuthorization-2.1 feature, changes in API behavior might require you to update your application code. For more information, see Differences between Jakarta Authorization 2.1 and 2.0.

Enabling this feature

To enable the Jakarta Authorization 2.1 feature, add the following element declaration into your server.xml file, inside the featureManager element:

<feature>appAuthorization-2.1</feature>

Standard API packages provided by this feature

  • jakarta.security.jacc

Liberty API packages provided by this feature

  • com.ibm.wsspi.security.authorization.jacc

Features that this feature enables

Supported Java versions

  • JavaSE-11.0

  • JavaSE-17.0

  • JavaSE-20.0

Features that enable this feature

Developing a feature that depends on this feature

If you are developing a feature that depends on this feature, include the following item in the Subsystem-Content header in your feature manifest file.

io.openliberty.appAuthorization-2.1; type="osgi.subsystem.feature"