Java Database Connectivity
4.3
4.2
4.1
4.0

This feature enables the configuration of DataSources to access Databases from applications. Any JDBC driver that complies with the JDBC 4.2, 4.1, 4.0, 3.0, or 2.x specification can be used; customized configuration of many specific providers is included. High performance connection pooling is also provided.

Enabling this feature

To enable the Java Database Connectivity 4.2 feature, add the following element declaration into your server.xml file, inside the featureManager element:

<feature>jdbc-4.2</feature>

Supported Java versions

  • JavaSE-1.8

  • JavaSE-11.0

  • JavaSE-14.0

Developing a feature that depends on this feature

If you are developing a feature that depends on this feature, include the following item in the Subsystem-Content header in your feature manifest file.

com.ibm.websphere.appserver.jdbc-4.2; type="osgi.subsystem.feature"