SIP Servlet 1.1

This feature enables support for SIP Servlets written to the Java SipServlet 1.1 specification. The servlets can be packaged in Java EE specified WAR, SAR or EAR files. If servlet security is required, an appSecurity feature should also be configured; in the absence of a security feature any security constraints for the application will be ignored.

Enabling this feature

To enable the SIP Servlet 1.1 feature, add the following element declaration into your server.xml file, inside the featureManager element:

<feature>sipServlet-1.1</feature>

Standard API packages provided by this feature

  • javax.servlet.sip

  • javax.servlet.sip.annotation

  • javax.servlet.sip.ar

  • javax.servlet.sip.ar.spi

Liberty API packages provided by this feature

  • com.ibm.websphere.sip

  • com.ibm.websphere.sip.resolver

  • com.ibm.websphere.sip.resolver.events

  • com.ibm.websphere.sip.resolver.exception

  • com.ibm.websphere.sip.unmatchedMessages

  • com.ibm.websphere.sip.unmatchedMessages.events

Features that this feature enables

Supported Java versions

  • JavaSE-1.8

  • JavaSE-11.0

  • JavaSE-14.0

Developing a feature that depends on this feature

If you are developing a feature that depends on this feature, include the following item in the Subsystem-Content header in your feature manifest file.

com.ibm.websphere.appserver.sipServlet-1.1; type="osgi.subsystem.feature"