JavaServer Pages
2.3
2.2

This feature enables support for Java Server Pages (JSPs) that are written to the JSP 2.3 specification. This framework simplifies the construction of user interfaces. Enabling this feature also enables the Expression Language (EL) version 3.0 feature.

Enabling this feature

To enable the JavaServer Pages 2.3 feature, add the following element declaration into your server.xml file, inside the featureManager element:

<feature>jsp-2.3</feature>

Feature configuration elements

Standard API packages provided by this feature

  • javax.el

  • javax.servlet.jsp

  • javax.servlet.jsp.el

  • javax.servlet.jsp.jstl.core

  • javax.servlet.jsp.jstl.fmt

  • javax.servlet.jsp.jstl.sql

  • javax.servlet.jsp.jstl.tlv

  • javax.servlet.jsp.tagext

Features that this feature enables

Supported Java versions

  • JavaSE-1.8

  • JavaSE-11.0

  • JavaSE-14.0

Developing a feature that depends on this feature

If you are developing a feature that depends on this feature, include the following item in the Subsystem-Content header in your feature manifest file.

com.ibm.websphere.appserver.jsp-2.3; type="osgi.subsystem.feature"

SPI packages provided by this feature

  • com.ibm.wsspi.jsp.taglib.config