Java EE Full Platform
8.0
7.0

This feature combines the Liberty features that support the Java EE 8.0 Full Platform.

Enabling this feature

To enable the Java EE Full Platform 8.0 feature, add the following element declaration into your server.xml file, inside the featureManager element:

<feature>javaee-8.0</feature>

Feature configuration elements

Supported Java versions

  • JavaSE-1.8

  • JavaSE-11.0

  • JavaSE-14.0

Developing a feature that depends on this feature

If you are developing a feature that depends on this feature, include the following item in the Subsystem-Content header in your feature manifest file.

com.ibm.websphere.appserver.javaee-8.0; type="osgi.subsystem.feature"