Enterprise JavaBeans 3.2

This feature enables support for Enterprise JavaBeans written to the EJB 3.2 specification.

Enabling this feature

To enable the Enterprise JavaBeans 3.2 feature, add the following element declaration into your server.xml file, inside the featureManager element:

<feature>ejb-3.2</feature>

Feature configuration elements

Supported Java versions

  • JavaSE-1.8

  • JavaSE-11.0

  • JavaSE-15.0

Features that enable this feature

Developing a feature that depends on this feature

If you are developing a feature that depends on this feature, include the following item in the Subsystem-Content header in your feature manifest file.

com.ibm.websphere.appserver.ejb-3.2; type="osgi.subsystem.feature"